HDOJ-----4006优先队列

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 9958    Accepted Submission(s): 3967


Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.
 

Output
The output consists of one integer representing the largest number of islands that all lie on one line.
 

Sample Input
  
  
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

Sample Output
 
 
1 2 3


刚开始有点迷------做题做多了就这样,醉了

就是给定一个k,一个人让另一个人写数字,然后问第k大的数是几,问题就是超时啦,定义一个元素数量为k的队列,一直更新优先队列就好了

就好像12345,第一大的是5,第3大的是3,要是一直问第k大的是几,就保留前k大的就好了


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<vector>
#include<functional>
using namespace std;
char s[101];
int main(){
    int a, k, ans;
    while(~scanf("%d%d", &a, &k)){
        priority_queue<int, vector<int>, greater<int> > que;//升序
        while(a--){
            scanf(" %s", s);
            if(s[0] == 'I'){
                scanf("%d", &ans);
                if(que.size() < k){
                    que.push(ans);
                }
                else if(ans > que.top()){//更新
                    que.pop();
                    que.push(ans);
                }
            }
            else{
                printf("%d\n", que.top());
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值