Light OJ-----1282对数快速幂

Description

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits ofnk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) andk (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such thatnk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669


求n的k次方前三位与后三位的值,后三位快速幂,前三位用到数学推论n^k = 10(k*log10(n)),log可以很快求出来,最终转化为求10的次方取前三位数

用pow函数,前三位的数只与k*log10(n)这个值的小数部分有关

还有后三位不一定满三位补出前导0


#include<cstdio>
#include<cstring>
#include<vector>
#include<map>
#include<queue>
#include<cmath>
#define inf 0x3f3f3f3f
#define mes(a, b) memset(a, b, sizeof(a))
using namespace std;
typedef long long LL;
const int maxn = 1e6+10;
LL solve(LL a, LL b){
	LL ans = 1;
	while(b){
		if(b & 1){
			ans = ans*a%1000;
		}
		b >>= 1;
		a = a*a%1000;
	}
	return ans;
}
int main(){
	int t, ans, kcase = 1;
	LL n, b;
    scanf("%d", &t);
    while(t--){
    	scanf("%lld%lld", &n, &b);
    	double c = b*log10(n+0.0);
    	c -= LL(c);
    	ans = (int)pow(10.0, c+2);
    	printf("Case %d: %d %03d\n", kcase++, ans, solve(n, b));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值