poj2479——Maximum sum(dp)

Description

Given a set of n integers: A={a1, a2,…, an}, we define a function d(A) as below:
这里写图片描述
Your task is to calculate d(A).
Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, …, an. (|ai| <= 10000).There is an empty line after each case.
Output

Print exactly one line for each test case. The line should contain the integer d(A).
Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5
Sample Output

13

正向求一遍最大子序列和,用dp1[i]表示从1到i的最大子序列和
反向求一遍dp2,道理如上
接下来只要一次遍历序列找最大值就过了

#include<iostream>
#include <cstdio>
#include <algorithm>
#include<cmath>
#include <cstring>
#define MAXN 50010
#define inf 0x3f3f3f3f
using namespace std;
long long dp1[MAXN],a[MAXN],dp2[MAXN],maxsum;
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; ++i)
            scanf("%I64d",&a[i]);
        int tmp=a[1];
        if(tmp<0)
        {
            tmp=0;
        }
        maxsum=a[1];
        dp1[1]=a[1];
        for(int i=2; i<=n; ++i)
        {
            tmp+=a[i];
            if(maxsum<tmp)
                maxsum=tmp;
            if(tmp<0)
                tmp=0;
            dp1[i]=maxsum;
        }
        tmp=a[n];
        if(tmp<0)
            tmp=0;
        maxsum=a[n];
        dp2[n]=a[n];
        for(int i=n-1; i>=1; --i)
        {
            tmp+=a[i];
            if(maxsum<tmp)
                maxsum=tmp;
            if(tmp<0)
                tmp=0;
            dp2[i]=maxsum;
        }
        maxsum=-999999999;
        for(int i=1; i<n; ++i)
        {
            int j=i+1;

            tmp=dp1[i]+dp2[j];
            if(tmp>maxsum)
                maxsum=tmp;
        }

        printf("%I64d\n",maxsum);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值