poj1611——The Suspects(并查集)

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1

给出一些团体里的人物编号,0号代表受感染的人,圈子里的人能够互相感染,问最终感染了多少人。
并查集类似一种树形结构吧,同一个团体里的人在一棵树上,所有人都用最初加入这个树的人编号表示。树的合并,也就是并查集的合并,找到各自所在的树的编号,再判断编号的等级,这里默认把一个团体的人合并到第一个人所造的树上,如果第一个人的编号等级比后面的人大,那就加入作为子树。
如果等级小,说明后面的人加入了一个更大的树,那么就要把第一个人所在的树加入后面的树。
如果等级相同,合并后把其中一个树的等级提高就行。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 200010
#define Mod 10001
using namespace std;
int f[MAXN],rank[MAXN];
int find(int x)
{
    if(x!=f[x])
    {
        f[x]=find(f[x]);
    }
    return f[x];
}
void join(int a,int b)
{
    a=find(a);
    b=find(b);
    if(a==b)
        return;
    if(rank[a]<rank[b])
        f[a]=b;
    else
    {
        f[b]=a;
        if(rank[a]==rank[b])
            rank[a]++;
    }
}
int main()
{
    int n,m,k,a,b;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        for(int i=0;i<=n;++i)
        {
            f[i]=i;
            rank[i]=0;
        }
        while(m--)
        {
            scanf("%d",&k);
            scanf("%d",&a);
            for(int i=1;i<k;++i)
            {
                scanf("%d",&b);
                join(a,b);
            }
        }
        int ans=1;
        for(int i=1;i<=n;++i)
        {
            if(find(i)==find(0))
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值