poj1251——Jungle Roads(prim)

Description

这里写图片描述

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
Sample Output

216
30

别看字,看图看样例

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 100
#define Mod 10001
using namespace std;
int n,map[MAXN][MAXN],vis[MAXN],dis[MAXN];
int prim()
{
    int i,j,pos,min,ans=0;
    memset(vis,0,sizeof(vis));
    vis[1]=1,pos=1;
    for(i=1; i<=n; ++i)
        if(i!=pos)
            dis[i]=map[pos][i];
    for(i=1; i<n; ++i)
    {
        min=INF;
        for(j=1; j<=n; ++j)
            if(!vis[j]&&dis[j]<min)
            {
                min=dis[j];
                pos=j;
            }
        ans+=min;
        vis[pos]=1;
        for(j=1; j<=n; ++j)
            if(!vis[j]&&dis[j]>map[pos][j])
                dis[j]=map[pos][j];
    }
    return ans;
}
int main()
{
    int k,w;
    char u,v;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=1;i<=n;++i)
            for(int j=1;j<=n;++j)
            map[i][j]=INF;
        for(int i=1; i<n; ++i)
        {
            cin>>u>>k;
            while(k--)
            {
                cin>>v>>w;
                map[u-'A'+1][v-'A'+1]=w;
                map[v-'A'+1][u-'A'+1]=w;
            }
        }
        printf("%d\n",prim());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值