hdoj 2894 Aaronson (贪心)

Aaronson

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 746    Accepted Submission(s): 412


Problem Description
Recently, Peter saw the equation x0+2x1+4x2+...+2mxm=n . He wants to find a solution (x0,x1,x2,...,xm) in such a manner that i=0mxi is minimum and every xi ( 0im ) is non-negative.
 

Input
There are multiple test cases. The first line of input contains an integer T (1T105) , indicating the number of test cases. For each test case:

The first contains two integers n and m (0n,m109) .
 

Output
For each test case, output the minimum value of i=0mxi .
 

Sample Input
  
  
10 1 2 3 2 5 2 10 2 10 3 10 4 13 5 20 4 11 11 12 3
 

Sample Output
  
  
1 2 2 3 2 2 3 2 3 2
 

题意:就是满足上面那个数学式。

题解:尽量使2^m*Xm中,2的次幂大的数相乘的数大,依次求到2的0次幂,

技巧:n最大是1e9,所以m大于31时按31算就行

代码:

#include<cstdio>
#include<cmath>
int min(int x,int y)
{
	return x<y?x:y;
}
int main()
{
	int t,n,m;
	int sum;
	scanf("%d",&t);
	while(t--)
	{
		sum=0;
		scanf("%d%d",&n,&m);
		m=min(m,31);
		for(int i=m;i>=0;i--)
		{			
			sum+=n/(1<<i);
			n=n%(1<<i);					
		}
		printf("%d\n",sum);
	}
	return 0;
 } 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值