NAT路由访问过程中源目端口源目IP的变化

ensp 同时被 3 个专栏收录
3 篇文章 0 订阅
1 篇文章 0 订阅
1 篇文章 0 订阅

拓扑图:

在这里插入图片描述

要求:

PC1 不能访问Internet
Client1 可以访问Internet
Server1 为Internet提供HTTP服务,不提供FTP服务
Client1 可以访问 Server2的HTTP和FTP
Client2 可以访问Server1的HTTP
Server1被访问的地址是200.1.1.3,Clinet1上网使用Easy IP方式完成。
Server2提供FTP服务和HTTP服务;Server2的FTP服务IP为200.1.1.4:2000;Server2的HTTP服务IP为200.1.1.5:8082

步骤1:配置 IP地址

R1:
interface GigabitEthernet0/0/0
ip address 192.168.1.1 255.255.255.0

interface Serial4/0/0
ip address 200.1.1.1 255.255.255.248

R2:
interface GigabitEthernet0/0/0
ip address 100.1.1.2 255.255.255.0

interface Serial4/0/0
ip address 200.1.1.2 255.255.255.248

步骤2:配置nat、静态路由使全网能互通

R1:
acl number 2001
rule 5 permit source 192.168.1.0 0.0.0.255

interface Serial4/0/0
nat outbound 2001

ip route-static 100.1.1.0 255.255.255.0 200.1.1.2

R2:
ip route-static 192.168.1.0 255.255.255.0 200.1.1.1

步骤3:创建规则,使PC1不能访问外网

R1:
acl number 2001
rule 10 deny source 192.168.1.100 0

步骤4:将Server1以地址200.1.1.3:8081发布:

R1:
interface Serial4/0/0
nat server protocol tcp global 200.1.1.3 8081 inside 192.168.1.200 www

client2访问server1:
在这里插入图片描述

步骤5:将Server2的FTP服务IP100.1.1.100:1010以IP200.1.1.4:2000发布;Server2的HTTP服务IP100.1.1.100:80以200.1.1.5:8082发布

R2:
interface Serial4/0/0
nat server protocol tcp global 200.1.1.5 8082 inside 100.1.1.200 www //发布HTTP服务
nat server protocol tcp global 200.1.1.4 2000 inside 100.1.1.200 1010 //发布FTP服务,ftp服务器端口我改成了1010

client1访问Server2过程中数据包五元组的变化抓包验证:在这里插入图片描述

在这里插入图片描述
在第一阶段 源地址为客户端IP,源端口为随机端口,目的地址是服务器发布的地址,目的端口为服务器发布的端口

第二阶段 源地址为客户端NAT地址,源端口为NAT路由器随机端口;目的地址为服务器发布的地址,目的端口为服务器发布的端口;

第三阶段,源地址为客户端NAT地址,端口为NAT路由器随机端口,目的地址为服务器内部地址,端口为服务器内部端口;

  • 0
    点赞
  • 0
    评论
  • 1
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 深蓝海洋 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值