yum安装docker报错

在centos版本 7.3中用yum安装后报错出现 Error starting daemon: SELinux is not supported with the overlay2 graph driver on this kernel. Either boot in...led=false) 根据日志得知,此linux的内核中的SELinux不支持 overlay2 graph driver ,解决方法有两个,要么启动一个新内核,要么就在docker里禁用selinux,--selinux-enabled=false
重新编辑docker配置文件:

# vim /etc/sysconfig/docker

# Modify these options if you want to change the way the docker daemon runs
OPTIONS='--selinux-enabled=false --log-driver=journald --signature-verification=false'
if [ -z "${DOCKER_CERT_PATH}" ]; then
    DOCKER_CERT_PATH=/etc/docker

fi

如上改为--selinux-enabled=false后保存,重启docker,搞定!


阅读更多
上一篇docker概念
下一篇二进制安装docker
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭