Thinking

兵胜非常事,要善于总结

yiluo-----Eclipse 插件Maven在使用 add dependency,找不到包,解决办法

文章来源:http://blog.csdn.net/yiluoak_47/article/details/12068817

Eclipse 插件Maven在使用 add dependency,找不到包,解决办法

通过右键单击pom.xml文件选择maven –> add dependency 或者是打开pom.xml文件,选择dependencies –>add 时,搜索不到依赖的jar包,解决方法如下:

1、eclipse菜单 window-> show view –> other –> Maven

2、在打开的窗口里,右键 local repositories –> local repository ,选择 rebuild index

转自:http://www.cnblogs.com/alex-blog/articles/2274428.html

 

一、maven的eclipse插件在增加依赖(Add Dependency)时无法搜索远程仓库

现象:无法搜索远程仓库,只能搜索本地仓库,如下图

问题分析与解答:没有配置可用的仓库或者仓库的索引损坏导致无法检索,首先打开eclipse中的Maven Repositories视图,查看是否存在远程仓库

如不存在远程仓库请配置(可自行搜索配置仓库的方法),若存在请在[central]上右击[Rebuilding Indexes],索引重建完毕后将可进行远程检索。

二、maven的eclipse插件有sonatype.org和eclipse.org两个,两个什么关系,有何不同

m2eclipse的插件最开始是由sonatype开发,现已交由eclipse基金会维护,现在的版本从1.0开始,建议下载:http://eclipse.org/m2e/

所以,现在看来就是只有一个版本eclipse.org的,sonatype已经不再更新了。

 

 

三、sts(springsource tool suite)2.8中集成的m2eclipse 1.0插件的POM editor无法显示高级选项(比如依赖图等)

查看官方文档发现:2.8版本已经将原来的m2e 0.12升级为1.0了,然后就没有了高级选项卡了,在官方论坛中有人提问

http://forum.springsource.org/showthread.php?120631-Advanced-Maven-Pom-Display

至于官方所说的,降级后需要修改.project .classpath文件,其实只要将原来的maven项目重新加入maven管理即可(个人意见)

转自:http://www.189works.com/article-42298-1.html


阅读更多
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭