Eclipse 配置tomcat8

目前最新的tomcat版本是8.x,但是下载最新的Eclipse服务器支持上面最多支持到tomcat7,如果想使用最新的tomcat8,可以通过这种更改配置文件的方式解决 (PS: 当然这是一种取巧的行为,不值得提倡 偷笑)。


使用Eclipse中的tomcat7 搭配 tomcat8服务会提示说7的版本不支持8,那想想我们是否直接修改tomcat8的版本配置文件,将tomcat8的版本信息伪装为7呢?


答案是肯定的。步骤如下:


1. 将 tomcat8 下lib中的catalina.jar 中的 \org\apache\catalina\util\ServerInfo.properties 配置文件拿出来

2. 打开properties配置文件,然后看到 

server.info=Apache Tomcat/8.0.11

server.number=8.0.11.0

3. 将版本号修改为Eclipse中的版本号

server.info=Apache Tomcat/7.0.47
server.number=7.0.47.0

4. 将这个配置文件放入\org\apache\catalina\util\路径下替换原有

重新配置,就可以使用Tomcat8了



没有更多推荐了,返回首页