1004. Counting Leaves

1004. Counting Leaves (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1
题目的意思是让我们建立一颗树,我们明白题目的重点在于某节点是否有孩子以及是上一层哪个节点的孩子。题目让我们输出的答案是每一层没有孩子节点的个数,我们首先需要建立这棵树,然后知道这棵树有多少层,再然后如何去保存上下层孩子节点的关系,然后从上往下扫描并进行输出!此题不难。基础题
#include<stdio.h>
using namespace std;

struct Node
{
	int parent;
	int level;
	bool has_child;//
}buf[102];

int max_level;//最大深度
int count[102];//保存每层的叶子节点数

int find_level(int i)
{
	if(buf[buf[i].parent].level == 0)
		return buf[i].level = find_level(buf[i].parent) + 1;
	else
		return buf[i].level = buf[buf[i].parent].level + 1;
}

int main()
{
	freopen("E://input.txt", "r", stdin);
	int n, m;
	scanf("%d%d", &n, &m);
	for(int i = 1; i <= n; i ++)
	{
		buf[i].parent = 0;
		buf[i].level = 0;
		buf[i].has_child = false;
		count[i] = 0;
	}
	
	for(int i = 1; i <= m; i ++)
	{
		int k, a, b;
		scanf("%d%d", &a, &k);
		buf[a].has_child = true;
		for(int j = 1; j <= k; j ++)
		{
			scanf("%d", &b);
			buf[b].parent = a;
		}
	}
	
	buf[1].level = 1;
	
	for(int i = 2; i <= n; i ++)
		find_level(i);
	
	for(int i = 1; i <= n; i ++)
	{
		if(max_level < buf[i].level)
			max_level = buf[i].level;
	}//找到最大的深度
	
	//找到各层中的叶子节点数 
	for(int i = 1; i <= n; i ++)
		if(buf[i].has_child == false)
			count[buf[i].level] ++; 
	
	
	for(int i = 1; i <= max_level; i ++)
	{
		if(i == max_level)
			printf("%d", count[i]);
		else
			printf("%d ", count[i]);
	} 

	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值