[PAT 甲级] 1014 Waiting in Line (30 分)

1014 Waiting in Line (30 分)

原题链接

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
​​ minutes to have his/her transaction processed.
The first N customers are assumed to be served at 8:00am.
Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer
Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:
For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output:
08:07
08:06
08:10
17:00
Sorry


这一题的坑点,让我很迷,有一个测试点过不了。除此之外,需要注意的坑点整理如下:

1.for those customers who cannot be served before 17:00, you must output Sorry instead. 如果你前面一个人完成时间是16点59分,那么你是可以继续询问的,即使你需要的服务时间很长,很长。。。在这里插入图片描述

2.这一句的意思是,你只看那个队伍可以排队,而不是看那一队伍更快完成,所以需要找到当前队头哪个人的完成时间最少,所以需要自行比较。在这里插入图片描述
3.即使我排除了上面的问题,同时思考过nmkq都是 positive integers,还是有一个测试点不对。挂在博客上希望大佬帮忙解决。在这里插入图片描述


#include<iostream>
#include<vector>
#include<queue>
using namespace std;

int n, m, k, q;
int tim[1001];
void print(int cnt) {
    cnt = tim[cnt - 1];
    if (cnt == 0) {
        printf("Sorry\n");
    } else {
        int h = cnt / 60;
        int s = cnt % 60;
        h = 8 + h;
        printf("%02d:%02d\n", h, s);
    }
}
int main () {
    cin >> n >> m >> k >> q;
    int cnt;
    if (m == 0) {
        m = 1;
    }
    vector<queue<int>> cp(n + 1); //记录窗口队列
    vector<int >cp1(n + 1, 0); //记录在每一个窗口前面等到到自己服务所需要的时间
    for (int i = 0; i < k; i++) {
        cin >> cnt;
        if (i < n * m) {
            cp1[i % n] += cnt;
            tim[i] = cp1[i % n];
            cp[i % n].push(tim[i]);
        } else {
            int min_j = 0, min_v = cp[0].front();
            for (int j = 1; j < n; j++) {
                if (min_v > cp[j].front()) {
                    min_v = cp[j].front();
                    min_j = j;
                }
            }
            cp[min_j].pop();
            cp[min_j].push(cp1[min_j] + cnt);
            if (cp1[min_j] < 540) {
                tim[i] = cp1[min_j] + cnt;
            } else {  //如果当前窗口所需要的时间
                tim[i] = 0;
            }
            cp1[min_j] += cnt;
        }
    }

    for (int i = 1; i <= q; i++) {
        cin >> cnt;
        print(cnt);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值