HDU 1016 Prime Ring Problem 简单DFS

Prime Ring Problem

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

Source

Asia 1996, Shanghai (Mainland China)

解题思路:
从1~N,N个数,围成一个环,要求相邻的两个数和为质数。当然,第一个数要求固定为1。搜索?搜索!深搜!!
首先考虑数据结构,即用什么来存储当前的数据环,考虑用数组。DFS的 本质就是递归,搜索无效返回的时候就要
回溯,体现在本题中就牵涉到一个数组的值得问题,即visit[21]数组,最初只有visit[0]被标记为1,其他全为0,在每一次
递归调用前先将当前位置所填充的数标记为1,在每一次回溯时将visit标记为0。那么,还有可以优化的地方吗?答案是肯定的。
在判断素数的时候我们可以用数组来标记,这样的一对一映射十分快。

源代码:
#include <iostream>
#include <string.h>
using namespace std;

int prime[40]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0};
int n,visit[21],a[21]={1};

void dfs(int x)
{
    if(x>=n&&prime[a[0]+a[x-1]])
    {
        cout<<a[0];
        for(int i=1;i<n;i++)
            cout<<' '<<a[i];
        cout<<endl;
    }
    else
    {
        for(int j=2;j<=n;j++)
        {
            if(prime[j+a[x-1]]&&!visit[j])
            {
                visit[j]=1;
                a[x]=j;
                dfs(x+1);
                visit[j]=0;
            }
        }
    }
}

int main()
{
    int ncase=1;
    while(cin>>n)
    {
        memset(visit,0,sizeof(visit));
        cout<<"Case "<<ncase++<<":"<<endl;
        dfs(1);
        cout<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值