Ionic自动更新8.0apk自动安装权限问题解决

项目中安卓强制更新,当文件下载完。在android 8.0中不能打开apk包。
根据cordova官网提示 android 8.0 需要添加配置文件。
Android APK安装限制,打开APK文件进行安装时,出现以下报错:
FileUriExposedException: file:///storage/emulated/0/test.txt exposed beyond app through Intent.getData()

为了能够兼容8.0,我们需要做如下修改:
1、需要在platform/android/mainfest.xml中添加ACTION_INSTALL_PACKAGE权限,如下:

2、需要修改platform/android/mainfest.xml中修改uses-sdk的值,其中android:targetSdkVersion最大 值不能超过23,否则会出错.
<uses-sdk android:minSdkVersion=”16” android:targetSdkVersion=”23” />

到此,即可解决android8.0的兼容性问题
参考链接:http://www.cnblogs.com/wupeng88/p/8567958.html

阅读更多
文章标签: ionic android8.0兼容
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭