xynuoj1748 奇怪的信

题目描述

One day, Tom received a strange letter. It asked Tom to calculate the number of digits in each digit which the digit is even.
For example: 5548, the result is 12, which is 4 + 8.
Tom is very upset and wants to ask you to help solve this problem.

输入

The input data has multiple groups. Each group occupies a row with only one integer, ensuring that the number is within the 32-bit integer range.

输出

For each group of input data, output a row, and there is a blank line between each pair of data.

样例输入

415326
3262

样例输出

12

10

#include<stdio.h>
#include<string.h>
int main()
{
    char a[32];
    while(scanf("%s",a)!=EOF)
    {
        int sum=0;
        int len=strlen(a);
        for(int i=0;i<len;i++)
        {
            if(((a[i]-'0')%2)==0)
            sum+=a[i]-'0';
        }
        printf("%d\n\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值