hdu1452 Happy 2004 因子和 取模乘法逆元 快速幂

Happy 2004

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2020    Accepted Submission(s): 1473


Problem Description
Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.
 

Input
The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000). 

A test case of X = 0 indicates the end of input, and should not be processed.
 

Output
For each test case, in a separate line, please output the result of S modulo 29.
 

Sample Input
 
 
1 10000 0
 

Sample Output
 
 
6 10
 

/*
φ(n) -欧拉函数
μ(n) -莫比乌斯函数,关于非平方数的质因子数目
gcd(n,k) -最大公因子,当k固定的情况
d(n) -n的正因子数目
σ(n) -n的所有正因子之和

题意:
求2004^x的所有的因子和 然后mod 29。
N的因子和是积性函数,所以就开始用积性函数的方法解题。
积性函数 : 当gcd(a,b)=1时 s(a*b)=s(a)*s(b);
如果p是素数(或素数取X模后的数)  s(p^n)=1+p+p^2+...+p^n= (p^(n+1)-1)/(p-1)
2004=2*2*3*167 质因子 
σ(2004^x)=σ(2^2x)*σ(3^x)*σ(167^x) mod 29 积性函数。 
因为 167 % 29 = 22  
所以σ(2004^x) = σ(2^2x)*σ(3^x)*σ(22^x) mod 29  

并且 σ(2^2x) = (2^(2x+1)-1)/(2-1) =(2^(2x+1)-1)/1  
 σ(3^x) = (3^(x+1)-1)/(3-1)       =(3^(x+1)-1) /2  
 σ(22^x) = (22^(x+1)-1)/(22-1)    =(22^(x+1)-1)/21 
 所以 
 σ(2004^x)=(2^(2x+1)-1)* (3^(x+1)-1)/2 *(22^(x+1)-1)/21 

 1/2 对于29的逆元x=15   1=2*15 -29*1   
 1/21对于29的逆元x=18   1=21*18-29*13  
 σ(2004^x)=((2^(2x+1)-1)*(3^(x+1)-1)*15*(22^(x+1)-1)*18)%29 

然后开始用快速幂求解。 这个题目的重点在在于这个数学推导过程。 
*/

#include"cmath"
#include"string"
#include"cstdio"
#include"cstring"
#include"iostream"
#include"algorithm"
using namespace std;
typedef long long LL;
 
LL mod_pow(LL x,LL y,LL p) { //快速幂 
    LL rt=1;
    LL t=x;
    while(y) {
        if(y&1)rt=(rt*t)%p;
        t=t*t%p;
        y>>=1;
    }
    return rt;
}
 
int main() {
    LL x,ans;
    while(~scanf("%I64d",&x)) {
        if(x==0)break;
        /*/ σ(2004^x)=((2^(2x+1)-1)*(3^(x+1)-1)*15*(22^(x+1)-1)*18)%29 /*/
        ans=1;
        ans*=(mod_pow(2,2*x+1,29)-1)%29;
        ans*=(mod_pow(3,x+1,29)-1)*15%29;
        ans*=(mod_pow(22,x+1,29)-1)*18%29;
        printf("%I64d\n",ans%29);
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值