TZOJ1272:Red and Black

题目链接:http://tzcoder.cn/acmhome/problemdetail.do?method=showdetail&id=1272

视屏讲解链接:【Red and Black——杂题选讲(DFS)】https://www.bilibili.com/video/BV1cM411x7Au?vd_source=2c6f0c5d33eca0d75d8c3ceb6375eb3e

题目描述

描述

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

输入

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

输出

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

样例输入

6 9

....#.

.....#

......

......

......

......

......

#@...#

.#..#.

11 9

.#.........

.#.#######.

.#.#.....#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#.......#.

.#########.

...........

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

###.###

...@...

###.###

..#.#..

..#.#..

0 0

样例输出

45

59

6

13

AC代码:

//作者:Baicheng Qu
//DFS
//TZOJ 1217
#include<bits/stdc++.h>
using namespace std;
#define maxn 50
char maze[maxn][maxn];
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
int n,m;
int sum=0;

bool check(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m)
    return true;
    return false;

}

void dfs(int x,int y)
{
    sum++;
    maze[x][y]='#';
    for(int i=0;i<4;i++)
    {
        int dx=x+dir[i][0];
        int dy=y+dir[i][1];
        if(check(dx,dy)&&maze[dx][dy]=='.')
        {
            maze[dx][dy]='#';
            dfs(dx,dy);
        }
    }


}

int main()
{
    while(cin>>m>>n){

    if(m==0&&n==0) break;
    int tx,ty;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            cin>>maze[i][j];
            if(maze[i][j]=='@')
            {
                tx=i;
                ty=j;

            }
        }
    }
    dfs(tx,ty);
    cout<<sum<<endl;
    sum=0;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

captainfly_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值