Unity版本与虚拟现实头盔Deepoon大朋版本测试

版权声明:本文为博主cartzhang原创文章,未经博主允许不得转载。http://blog.csdn.net/cartzhang https://blog.csdn.net/cartzhang/article/details/50524654

本文章由cartzhang编写,转载请注明出处。 所有权利保留。
文章链接:http://blog.csdn.net/cartzhang/article/details/50524654
作者:cartzhang

OCulus DK2比较贵,再说,现在大家开始哄抢CV1,我本着有啥资源,就开弄的原则。
测试了下,我能用的手边有的大朋Deepoon头盔。

一、看这里

Unity官方与OC runtime版本兼容性说明:
https://developer.oculus.com/documentation/game-engines/latest/concepts/unity-sdk-version-compatibility/

需要测试的是Unity与大朋,Unity与DK2 runtime的版本。

二、Unity5.3版本搭配OC runtime 0.8版本

先说,Oculus Dk2,现有的Unity版本5.3.0版,测试过,直接PlayerSetting中勾选Virtual Reality Supported,OC runtime版本0.8.0,直接肯定是没有问题的嘛。
在编辑器模式下,直接可以在DK2头盔中看到效果。

既然这样,我就顺带把大朋拿来用用,同样环境,大鹏插上,同样可用,也可以在大朋VR头盔中看到Unity编辑效果。

三、Unity5.1版本搭配大鹏0.4版本

说明使用的是大朋特别定制版本的,内部版本号:1.2.4.81,对于OC runtime版本为0.6.0.1,不要问我咋知道的,我们是定制啊。

大朋有个切换模式,我需要Dk2模式,切换到Dk2模型下。

在Unity版本为5.1.1版本,编辑器模型下,同样勾选PlayerSetting中勾选Virtual Reality Supported,结果发现,大朋头盔上可以用的,完全没有问题。

但是在Unity5.3版本下,同样设置,大朋则不可用。这个是Unity官方都说了,5.3针对VR做了优化处理,必须要匹配OC runtime 0.8.0版本,还有可能需要更新显卡驱动。

当然,驱动我都更新过了。
所以,所做实验是真实可靠的啊。

四、做个表格,方便看

这里写图片描述

—————THE ———————-END———
以上,就是这样!!!
若有问题,请随时联系!
非常感谢!!

展开阅读全文

没有更多推荐了,返回首页