ERROR: 32-bit Linux Android emulator binaries are DEPRECATED

如果你的linux机子是32位的,那么运行android模拟器的时候会报错,如下:

ERROR: 32-bit Linux Android emulator binaries are DEPRECATED, to use them
you will have to do at least one of the following:
- Use the '-force-32bit' option when invoking 'emulator'.
- Set ANDROID_EMULATOR_FORCE_32BIT to 'true' in your environment.
Either one will allow you to use the 32-bit binaries, but please be aware that these will disappear in a future Android SDK release.
Consider moving to a 64-bit Linux system before that happens.


Android模拟器在64位系统上运行最好,所以最好的解决办法是重新安装64位的linux系统,如果暂时重装系统比较麻烦的话,有以下两种方法来解决:

1. 在你要运行的个工程右击->Run as -> Run configuration->Android application-> emulator , 滚动条拉到最后,找到commandline输入框,输入"-force-32bit",然后apply即可。

2. 配置环境变量,加上ANDROID_EMULATOR_FORCE_32BIT=true


原文请见 http://askubuntu.com/questions/534044/error-32-bit-linux-android-emulator-binaries-are-deprecated-when-attemping-to-r

©️2020 CSDN 皮肤主题: 大白 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值