[字典树] poj 2001 Shortest Prefixes

题目链接:

http://poj.org/problem?id=2001

Shortest Prefixes
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 12631 Accepted: 5387

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

Source

[Submit]   [Go Back]   [Status]   [Discuss]


题目意思:

给n个串,求每个串的不和其他串冲突的前缀。

解题思路:

字典树。

保存一个包含当前路径的单词个数,当个数为1时,说明没有冲突可以作为前缀。

代码:

//#include<CSpreadSheet.h>

#include<iostream>
#include<cmath>
#include<cstdio>
#include<sstream>
#include<cstdlib>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<list>
#include<queue>
#include<ctime>
#include<bitset>
#include<cmath>
#define eps 1e-6
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define ll __int64
#define LL long long
#define lson l,m,(rt<<1)
#define rson m+1,r,(rt<<1)|1
#define M 1000000007
//#pragma comment(linker, "/STACK:1024000000,1024000000")
using namespace std;

#define Maxn 1100
#define Maxm 26
char save[Maxn][25];

struct Node
{
    int cnt; //包含该路径的单词数
    struct Node * next[Maxm];
}root,node[Maxn*22];
int p;

void inse(char * word)
{
    Node * pos=&root;

    while(*word)
    {
        if(pos->next[*word-'a']==NULL) //之前没出现过
        {
            node[p].cnt=0; //初始化
            memset(node[p].next,NULL,sizeof(node[p]));//初始化
            pos->next[*word-'a']=&node[p++];//静态节点
        }
        pos=pos->next[*word-'a'];//往下
        pos->cnt++;
        word++;
    }
}

void query(char * word)
{
    Node * pos=&root;

    while(*word)
    {
        if(pos->cnt==1) //找到
            break;
        printf("%c",*word); //输出
        pos=pos->next[*word-'a'];
        word++;
    }
    putchar('\n');
}

int main()
{
   //freopen("in.txt","r",stdin);
   //freopen("out.txt","w",stdout);
   int k=0;
   p=0;
   memset(root.next,NULL,sizeof(root.next));

   while(~scanf("%s",save[k]))
        inse(save[k++]);

   for(int i=0;i<k;i++)
   {
       printf("%s ",save[i]);
       query(save[i]);

   }
   return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值