vs2017支持所有版本VC

转的可能之后自己会用到。

前言

研究目标:VS2017作为目前最新的IDE,让其支持所有版本的VC编译环境

必要性:报建通依赖的特定版本的AutoCAD作为“宿主”环境,作为一个通用产品,就需要支持所有的AutoCAD版本。现在AutoCAD版本需要支持的版本有AutoCAD 2005-2015,其中从AutoCAD 2010开始支持x64,按照一般情况,就需要针对每一个版本安装一个对应的Visual Studio IDE版本,这样给“环境的搭建”、“项目工程的管理”带来很大的挑战和负担

难点:目前每个Visual Studio集成编译环境仅支持对应版本的工程,且作为微软闭源的产品,不支持人为配置


总体说明


具体步骤

第一步:修改三个目录






第二步:复制Visual Studio目录







所需文件下载地址


链接: https://pan.baidu.com/s/1i58F0l3 

密码: ue9i


阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页