poj 3041 二分图匹配一般 匈牙利算法

点击打开题目

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23806 Accepted: 12912

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2
题意:给你长为n的正方形,其中有k个点你要消除,你可以一次性消除一行或者一次性消除一列,问最小消除几次才能全部消除这些点。

思路:这个题想通了就是水题,想不通就gg,其实这个题可以把(x,y)看做对立的点进行二分图匹配,然后,就是模板了。

#include<stdio.h>
#include<string.h>
int G[500][500];
int link[500],used[500];
int n,k;
int dfs(int u)
{
	for(int i=1;i<=n;i++)
	{
		if(G[u][i]&&!used[i])
		{
			used[i]=1;
			if(!link[i]||dfs(link[i]))
			{
				link[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	while(~scanf("%d%d",&n,&k))
	{
		int i,u,v,ans=0;
		memset(G,0,sizeof(G));
		memset(link,0,sizeof(link));
		for(i=0;i<k;i++)
		{
			scanf("%d%d",&u,&v);
			G[u][v]=1;
		}
		for(i=1;i<=n;i++)
		{
			memset(used,0,sizeof(used));
			ans+=dfs(i);
		}
		printf("%d\n",ans);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

长沙橘子猫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值