POJ 1915 Knight Moves【裸BFS || aStar*入门演练】

http://poj.org/problem?id=1915

Knight Moves
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 19848 Accepted: 9170

Description

Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 

Input

The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0

Source

TUD Programming Contest 2001, Darmstadt, Germany

[Submit]   [Go Back]   [Status]   [Discuss]



裸体一枚,纪念两年的失败后的重新开始

依稀记得某位牛人博客中这样一句话:

 ACM-ICPC绝不是大学生活的全部,也不是搞算法的全部,你大可以花时间去做其他研究,做项目,或者参加学生工作(我更欣赏那些对人生和职业有良好规划的ACMer);但是,如果你搞ICPC的那段时间你不是全部投入,那的在ACM-ICPC生涯中,将只有后悔。

/*
POJ 1915 Knight Moves【裸BFS】
题意:给出起点和终点求最小到达的步数
author:free斩
*/
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

const int maxn = 300+10;
int dir[8][2] = {1,2, 2,1, 2,-1, 1,-2, -1,-2, -2,-1, -2,1, -1,2};
int vis[maxn][maxn];
int n;
int st_x, st_y, en_x, en_y;

struct Node{
    int x,y;
    int step;
}node;

void bfs()
{
    queue<Node> q;
    while(!q.empty()) q.pop();

    Node first, next;
    first.x = st_x; first.y = st_y; first.step = 0;

    memset(vis, 0, sizeof(vis));
    vis[st_x][st_y] = 1;


    q.push(first);
    while(!q.empty())
    {
        Node now;
        now = q.front();
        q.pop();

        for(int i = 0; i < 8; i++)
        {
            next.x = now.x+dir[i][0];
            next.y = now.y+dir[i][1];

            if(!vis[next.x][next.y] && next.x >= 0 && next.x < n && next.y >= 0 && next.y < n)
            {
                next.step = now.step+1;
                q.push(next);

                vis[next.x][next.y] = 1;

                if(next.x == en_x && next.y == en_y)
                {
                    printf("%d\n", next.step);
                    return;
                }
            }
        }
    }

    return;

}
int main()
{
    int Test;
    scanf("%d", &Test);
    while(Test--)
    {
        scanf("%d", &n);
        scanf("%d%d", &st_x, &st_y);
        scanf("%d%d", &en_x, &en_y);

        if(st_x == en_x && st_y == en_y) {
            printf("0\n");
            continue;
        }
        else bfs();
    }

    return 0;
}

下面贴个刚学完 A*后写的代码:

/*
POJ 1915 Knight Moves【裸BFS】
题意:给出起点和终点求最小到达的步数
PS: 如果用数组模拟,则注意数组是否开小
算法:Astar* 入门演练
author:free斩
*/

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
#include<math.h>
using namespace std;

const int maxn = 300+10;
int dir[8][2] = {1,2, 2,1, 2,-1, 1,-2, -1,-2, -2,-1, -2,1, -1,2};
int vis[maxn][maxn];
int n;
int st_x, st_y, en_x, en_y;

struct Node{
    int x,y;
    int step;

    int f,g,h;// f = g + h;
    //G 起点到当前点的费用
    //H 当前点到终点的估计费用【此处是欧几里得距离】

    Node(){}
    Node(int _x, int _y, int _step, int _g, int _h)
    {
        x = _x; y = _y; step = _step;
        g = _g; h = _h; f = _g + _h;
    }
//用于构造优先队列,先查找 F 小的节点
    bool operator < (const Node &a) const {
        return a.f < f;
    }

}node;

bool isInMap(int x, int y)
{
    if(x < 0 || x >= n || y < 0 || y >= n) return false;
    return true;
}

//从(x,y) 到终点的估计费用 【欧几里得距离】
int getH(int x, int y)
{
    double dist = sqrt((double)(x-en_x)*(x-en_x) + (double)(y-en_y)*(y-en_y))*10;
    return (int)dist;
}
void bfs()
{
    priority_queue<Node> q;
    while(!q.empty()) q.pop();

    Node first, next;
    first.x = st_x; first.y = st_y; first.step = 0;
    first.h = getH(st_x, st_y);
    first.g = 0;
    first.f = first.h + first.g;

    memset(vis, 0, sizeof(vis));
    vis[st_x][st_y] = 1;


    q.push(first);
    while(!q.empty())
    {
        Node now;
        now = q.top();
        q.pop();
        for(int i = 0; i < 8; i++)
        {
            next.x = now.x+dir[i][0];
            next.y = now.y+dir[i][1];

            if(!vis[next.x][next.y] && next.x >= 0 && next.x < n && next.y >= 0 && next.y < n)
            {
                next.step = now.step+1;
                next.g = now.g + 23;
                next.h = getH(next.x, next.y);
                next.f = next.g + next.h;
                q.push(next);

                vis[next.x][next.y] = 1;

                if(next.x == en_x && next.y == en_y)
                {
                    printf("%d\n", next.step);
                    return;
                }
            }
        }
    }
//printf("not fond\n");
    return;

}
int main()
{
//freopen("out1.txt", "w", stdout);
    int Test;
    scanf("%d", &Test);
    while(Test--)
    {
        scanf("%d", &n);
        scanf("%d%d", &st_x, &st_y);
        scanf("%d%d", &en_x, &en_y);

        if(st_x == en_x && st_y == en_y) {
            printf("0\n");
            continue;
        }
        else bfs();
    }

    return 0;
}

/*
Sample Input
3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1


Sample Output
5
28
0

*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值