poj-2506 Tiling

1 篇文章 0 订阅

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

    递推,从1开始画,数出4有几种情况基本就能得到递推公式了。关键需要注意的是,当n=0的时候输出的答案是1。(坑爹啊明明面积是0为何还要用一块板子)高精度运算就不多提了。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    int n,x,t,i,p;
    int arr[300][500];
    while (scanf("%d",&n)!=EOF)
    {
            memset(arr,0,sizeof(arr));
            arr[0][0]=1;
            arr[1][0]=1;
            arr[2][0]=3;
            if(n==1||n==2||n==0)
            printf("%d\n",arr[n][0]);
            else
            {
                    for (i=3;i<=n;i++)
                    {
                            p=0;
                            for (t=0;t<500;t++)
                            {
                                    arr[i][t] = arr[i-1][t]+2*arr[i-2][t]+p;
                                    p=arr[i][t]/10;
                                    arr[i][t] %= 10;
                            }
                    }
                    for (i=499;i>=0;i--)
                    {
                            if(arr[n][i]!=0)
                            {
                                    for (;i>=0;i--)
                                    {
                                            printf("%d",arr[n][i]);
                                    }
                            }
                    }
                    printf("\n");
            }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值