南邮 OJ 1086 A + B Problem (3)

A + B Problem (3)

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 2699            测试通过 : 1690 

比赛描述

Calculate a + b.

输入

The input will consist of an integer N in the first line, and N pairs of integers a and b,separated by a space, one pair of integers per line.

输出

For each pair of input integers a and b you should output the sum of a and b in one line,and with one line of output for each line in input.

样例输入

2
1 5
3 3

样例输出

6
6

题目来源



/*    468ms
#include<iostream>
using namespace std;
int main(){
	int N,a,b;
	cin>>N;
	while(N--){
		cin>>a>>b;
		cout<<a+b<<endl;
	}
}*/
/*下面的程序只要46ms
#include<stdio.h>
int main(){
	int N,a,b;
	scanf("%d",&N);
	while(N--){
		scanf("%d%d",&a,&b);
		printf("%d\n",a+b);
	}
}*/
/*下面的程序119ms
#include<iostream>
int main(){
	int N,a,b;
	scanf("%d",&N);
	while(N--){
		scanf("%d%d",&a,&b);
		std::cout<<a+b<<std::endl;
	}
}*/
//下面的程序114ms
#include<iostream>
using namespace std;
int main(){
	int N,a,b;
	scanf("%d",&N);
	while(N--){
		scanf("%d%d",&a,&b);
		cout<<a+b<<endl;
	}
}

//所以用scanf 和 printf 快





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值