南邮 OJ 1101 Trees on the Level

Trees on the Level

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 391            测试通过 : 98 

比赛描述

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.
This problem involves building and traversing binary trees.
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have fewer than 256 nodes.
In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.
For example, a level order traversal of the tree

is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.



输入

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses. 
All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file. 

输出

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed.

样例输入

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

样例输出

5 4 8 11 13 4 7 2 1
not complete



#include<iostream>
#include<vector>
#include<string>
#include<set>
using namespace std;

struct nodeInfo{
	string content;
	string pos; 
};
bool operator<(const nodeInfo& n1,const nodeInfo& n2){
	if(n1.pos.size()!=n2.pos.size())
		return n1.pos.size()<n2.pos.size();
	else
		return n1.pos<n2.pos;
}
int main(){
	int i,n;
	bool treeIsComplete;
	string str;
	nodeInfo node;
	set<nodeInfo> nodes;
	set<nodeInfo>::iterator it;
	while(cin>>str){
		treeIsComplete = 1;
		nodes.clear();
		while(str!="()"){
			n = (int)str.size();
			for(i=0;i<n;++i){
				if(str[i]==','){
					break;
				}
			}
			node.content = str.substr(1,i-1);
			node.pos = str.substr(i+1,n-i-2);
			if(!nodes.count(node)){
				nodes.insert(node);
			}else{
				treeIsComplete = 0;				//重复插入
				break;		
			}
			cin>>str;
		}
		if(treeIsComplete && nodes.size()>1){
			for(it=nodes.begin(),++it;it!=nodes.end();++it){
				str = it->pos;
				str = str.substr(0,str.size()-1);
				node.pos = str;
				if(!nodes.count(node)){
					treeIsComplete = 0;			//没有父节点
					break;
				}
			}
		}
		if(!treeIsComplete){
			cout<<"not complete"<<endl;
			continue;
		}
		it = nodes.begin();
		cout<<it->content;
		for(++it;it!=nodes.end();++it){
			cout<<" "<<it->content;
		}
		cout<<endl;
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值