ubuntu无法安装ia32-libs库,提示没有可用的软件包

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/u013256831/article/details/40959989
Debian项目宣布,预计于2013年发布的Debian 7(代号Wheezy)将支持Multiarch。 

     Multiarch(多架构)术语被用于指一个系统能安装和运行有多个不同二进制文件的应用程序,例如i386-linux-gnu程序能运行在amd64-linux-gnu系统上。Multiarch还简化了跨架构编译。Debian在年度会议DebConf11上作出了引入Multiarch支持的决定。开发者表示,它大大增强了Debian实现通用操作系统承诺的能力,加强了新的64位系统对32位应用程序的支持。

1,在用的架构:

  1. dpkg --print-architecture
复制代码
输出当前的使用的架构,比如amd64
2,添加架构
  1. dpkg --add-architecture i386
复制代码
添加i386架构,然后刷新下源列表,当然,删除就是remove
  1. apt-get update
复制代码
这时就已经包含i386的软件列表
3,安装i386软件
  1. apt-get install iceweasel:i386
复制代码
这样就行了

展开阅读全文

没有更多推荐了,返回首页