E - Super Jumping! Jumping! Jumping! (求最大的递增子序列的和,不用连续)

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
Your task is to output the maximum value according to the given chessmen list. 

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
A test case starting with 0 terminates the input and this test case is not to be processed. 

Output

For each case, print the maximum according to rules, and one line one case. 

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

解题心得:题意:求最大的递增子序列的和,不用连续,例如(1,5,2),那么(1,2)也算他的递增子序列。 

  我刚开始做了一遍,忽略了不用连续这个问题,结果发现好简单,提交就是不对,应当注意这里。

  这个还是得用动态规划去做,最后的最优结果是由上一步的结果加上上一次的决策。n个数,由n-1个数的结果加上第n个数。n-1个数由n-2个数的结果。。。。。

  推倒最后,前两个数的的结果就很容易求了.以数列(3,2,4,2,3,6)为例。

 

  

下标i012345
a[i]324236
sum[i]3272513
ans0377513

  

 

 

 

 

  我觉得这个题动态规划思想一定要理解那两句‘重要代码’。

  另外发现一个事情,max()函数不用单独再去定义了,c++里面可以直接调用,不用再写#define max(a,b) a>b ? a:b 这一句了。

#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
const int N=1000001;
const int inf=0x3f3f3f;
int a[N];
int b[N];
int dp[N];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)break;
        for(int i=0; i<n; i++)
            cin>>a[i];
        int ans;
        b[0]=a[0];
        ans=b[0];
        for(int i=0; i<n; i++)
        {
            b[i]=a[i];
            for(int j=0; j<i; j++)
            {
                if(a[j]<a[i])
                {
                    b[i]=max(b[i],b[j]+a[i]);
                }
            }
            ans=max(ans,b[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值