Pseudoprime numbers POJ - 3641 (快速幂+素数)

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-apseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-apseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

题意:

  • 给出 p 和 a,若 a^p 对 p 取余且 p 不是素数,则输出 yes,否则输出 no

思路:

  • 大整数快速幂求模,加素数判断

快速幂算法 

#include <iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<stdio.h>
using namespace std;
typedef long long ll;
ll p,a;
bool is_prime(ll n)
{
    for(ll i=2;i<=sqrt(1.0*n);i++)
    {
        if(n%i==0)
        {
            return false;
        }
    }
    return true;
}
ll smPow_Mod(ll a,ll b,ll mod)
{
    ll res=1;
    while(b)
    {
        if(b&1)//如果幂数是奇数,则将底数保存在res中,这样幂数-1变成偶数就可以继续降幂了。b是幂数。

        {

            res=(res*a)%mod;//保存并更新多幂底数

        }
        a=(a*a)%mod;//更新底数

        b>>=1;//更新幂数

    }
    return res;
}
int main()
{
    while(~scanf("%lld%lld",&p,&a))
    {
        if(p==0&&a==0)
            break;
        if(!is_prime(p)&&smPow_Mod(a,p,p)==a%p)
        {
            printf("yes\n");
        }
        else printf("no\n");
    }
    return 0;
}

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值