Qt WebEngine版本要求

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chengdongyuan/article/details/79043863

WebEngine是Qt5.4之后加入的新特性,用Qt WebEngine取代之前的Qt Webkit
http://wiki.qt.io/QtWebEngine


windows版本

windows版本需要vs2013支持,下面是官方文档的原话:

Building on Windows currently requires Visual Studio 2013 or Visual Studio 2013 Express Edition This will most likely remain a requirement for Qt WebEngine. Changing it would require significant changes to the Chromium code base that are going against the direction Chromium is being developed.

从官方文档来看,目前在Windows上的构建需要Visual Studio 2013或Visual Studio 2013 Express Edition,这很可能仍然是Qt WebEngine的一个需求。
所以要想在windows下使用Qt WebEngine模块需要下载qt对应的vs2013版本。


linux

通过实践发现rhel6.5系统之上通过源码安装Qt5.4.2之后,编译使用webengine的项目是报错:
Project ERROR: Unknown module(s) in QT: webenginewidgets
猜想Qt5.4.2可能不支持该模块。
于是想安装Qt5.5.1查阅文档后发现Qt5.5.1需要红帽6.6系统。
733708-20170622093449866-751866377.png



后续:
linux下qt5.4.2源码编译安装没有Qt WebEngine模块,可能是gcc版本问题,所需的gcc版本为GCC version 4.7 。

展开阅读全文

没有更多推荐了,返回首页