复试训练——日期类问题

关于日期类问题同样是机试的核心,但只要把握住核心,解决这类问题难度不大。

题目1096:日期差值

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:11292

解决:3761

题目描述:

有两个日期,求两个日期之间的天数,如果两个日期是连续的我们规定他们之间的天数为两天

输入:

有多组数据,每组数据有两行,分别表示两个日期,形式为YYYYMMDD

输出:

每组数据输出一行,即日期差值

样例输入:

20110412
20110422

样例输出:

11

来源:

2009年上海交通大学计算机研究生机试真题

#include <stdio.h>
#define ISYEAR(x) x%100!=0 && x%4==0||x%400==0 ?1:0
int dayofMonth[13][2]={
     0,0,
     31,31,
	 28,29,
	 31,31,
	 30,30,
	 31,31,
	 30,30,
	 31,31,
	 31,31,
	 30,30,
	 31,31,
	 30,30,
	 31,31
};
struct Date{
 int Day;
 int Month;
 int Year;
 void nextDay(){
  Day++;
	  if(Day>dayofMonth[Month][ISYEAR(Year)]){
		  Day=1;
		  Month++;
		  if(Month>12){
		  Month=1;
		  Year++;
		  }
	  }
 }
};
int buf[5001][13][32];
int Abs(int x){
	return x<0? -x:x;
}
int main(){
	Date tmp;
	int cnt=0;
	tmp.Day=1;
	tmp.Month=1;
	tmp.Year=0;
		printf("--hello--1");
	while(tmp.Year!=5001){
		buf[tmp.Year][tmp.Month][tmp.Day]=cnt;
		tmp.nextDay();
		cnt++;
	}
	int d1,m1,y1;
	int d2,m2,y2;
	printf("--hello--2");
	while(scanf("%4d%2d%2d",&y1,&m1,&d1)!=EOF){
	      scanf("%4d%2d%2d",&y2,&m2,&d2);
		  printf("%d\n" ,Abs(buf[y2][m2][d2]-buf[y1][m1][d1])+1);
	}
	return 0;
}

题目1043:Day of Week

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:7533

解决:2636

题目描述:

We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入:

There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

输出:

Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

样例输入:

9 October 2001
14 October 2001

样例输出:

Tuesday
Sunday

提示:

Month and Week name in Input/Output:
January, February, March, April, May, June, July, August, September, October, November, December
Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday

来源:

2008年上海交通大学计算机研究生机试真题

代码:

#include <stdio.h>
#include <string.h>
#define ISYEAR(x) x%100!=0 &&x%4==0 ||x%400==0
int dayofMonth[13][2]={
     0,0,
     31,31,
	 28,29,
	 31,31,
	 30,30,
	 31,31,
	 30,30,
	 31,31,
	 31,31,
	 30,30,
	 31,31,
	 30,30,
	 31,31
};
struct Date{
	int Day;
	int Month;
	int Year;
	void nextDay(){
		Day++;
		if(Day>dayofMonth[Month][ISYEAR(Year)]){
		 Day=1;
		 Month++;
		 if(Month>12){
		 Month=1;
		 Year++;
		 }
		}

	}
};
int buf[3001][13][32];
char monthName[13][20]={
    "",
	"January",
	"Februry",
	"March",
	"April",
	"May",
	"June",
	"July",
	"August",
	"September",
	"October",
	"November",
	"December"
};
char weekName[7][20]={
     "Sunday",
	 "Monday",
	 "Tuesday",
	 "Wednesday",
	 "Thurday",
	 "Friday",
	 "Saturday"
};
int main(){
    Date tmp;
	int cnt=0;
	tmp.Day=1;
	tmp.Month=1;
	tmp.Year=0;
	while(tmp.Year!=3001){
	buf[tmp.Year][tmp.Month][tmp.Day]=cnt;
	tmp.nextDay();
	cnt++;
	}
	int d,m,y;
	char s[20];
	while(scanf("%d%s%d",&d,&s,&y)!=EOF){
		for(m=1;m<=12;m++){
		if(strcmp(s,monthName[m])==0)
			break;
		}

	int days=buf[y][m][d]-buf[2012][7][16];
	days+=1;
	puts(weekName[(days%7+7)%7]);
	}
	return 0;
}

 

转载于:https://my.oschina.net/u/1996306/blog/830861

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值