SOJ 1047. Super Snooker

1047. Super Snooker

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

On one of my many interplanetary travels I landed on a beautiful little planet called Crucible. It was inhabited by an extremely peace-loving people who called themselves Snooks. They received me very gracefully and told me I had arrived at precisely the right time, as the biggest event of the year was just then taking place: the Super Snooker Championship. Of course I couldn’t decline an invitation to go and watch. 
That year the Super Snooker Championship was contested by two experienced Snooks universally ac-claimed as the best players on the planet: Stephanie McHendry and Joanna McHiggins. The game involved an immense rectangular table covered with green cloth and lined by edges two inches high, except in the four corners and in the middle of the longer sides where there were holes. On it were put a number of balls (from 6 up to as many as 25), each representing a value or certain number of points (anywhere from 2 to 1000, but numbered consecutively). Each player in turn tried to nudge the lowest valued ball left on the table into one of the holes on the edges of the table using a strange limb called a “kew”. If one succeeded, she was said to have “podded” the ball and the value of the podded ball was added to her score. 
But here is the strange thing: the object of the game was not to finish with more points than the opponent. No, being a people who loved peace above all else, the object for both players was to end up with an equal number of points. This presented a bit of a problem. It was very important to them to know if it was possible to finish equal given the score of both players and the values of the balls left on the table. For instance, with a score-line of 56–34 and three balls left with values 13, 14 and 15, it is impossible to reach equal end-scores. If there are five balls left with values 20–24, it is possible: 56 + 20 + 24 = 34 + 21 + 22 + 23 = 100. You are asked to write a program that helps the Snooks by calculating whether it is possible for two Super Snooker players to win their game by finishing equal, given a score-line and the range of values of the range of the remaining balls. 

Input

The input consists of a line containing the number of configurations N (0 ≤ N ≤ 10000) to be calculated. It is followed by N lines each containing two scores and the lowest and highest values of the remaining balls.

Output

The output consists of one line for each configuration with the string ‘possible’ or the string ‘not possible’, depending on whether it is possible or not to finish equal from the given configuration.

Sample Input

5
56 34 13 15
56 34 20 24
0 0 500 519
0 0 500 520
0 0 500 521

Sample Output

not possible
possible
possible
not possible
not possible
关键要理解题意,用数学表达式解挺容易的。
#include<iostream>
#include<queue>
using namespace std;
int main(int argc, char const *argv[])
{
	
	int casen;
	cin>>casen;
	while(casen--)
	{
		int a,b,lower,upper,sum=0;
		cin>>a>>b>>lower>>upper;
		int leng=upper-lower+1;
		bool flag=false;
		if(a>b)
			swap(a,b);
		int  temp=b-a+(lower+upper)*(upper-lower+1)/2;
		if(temp%2==1||temp<0)
		{
			cout<<"not possible"<<endl;
			continue;
		}
		temp/=2;
       for (int i = 1; i <= leng; ++i)
       {
       	/* code */int min=(lower+i-1+lower)*i/2;
       	          int max=(upper+upper-i+1)*i/2;
       	          //cout<<temp<<" is temp"<<endl;
       	         // cout<<min<<"is min"<<max<<"is max"<<endl; 从数组中选取i个元素的最大最小值哦,之前看了很多变都是错了。
       	          if(min<=temp&&temp<=max)
       	          {
       	          	flag=true;
       	          	break;
       	          }
       }
       if(flag)
       {
       	cout<<"possible"<<endl;
       }
       else 
       	cout<<"not possible"<<endl;
		
			
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值