如何让JBuilder9支持Struts 1.1

原创 2004年08月09日 22:44:00

Struts1.1比Struts1.0功能增强了很多。比如:提供DynaActionForms,可不用编写任何代码创建动态的ActionForm;多应用支持允许定义多个struts-config.xml配置文件等等。但JBuilder 9只直接支持Struts1.0,不直接支持Struts1.1,下面让我们来看看怎样让JBuilder 9支持Struts1.1。

首先下载 jakarta-struts-1.1,把整个目录放到<jbuilder的安装目录>/extras目录下。

  接着在JBuilder用 Configure Libraries对话框 (Tools-->Configure Libraries)创建一个新的library ,我们命名为Struts1.1,把jakarta-struts-1.1/lib目录下所有的jar添加到新的library里(见图1),在library Settings里设置Framework为Struts,点OK,设置完成。

120360.jpg
图1

  接下来看看设置是否成功:

File-->New创建一个web application, 在Web Application wizard的JSP/Servlet frameworks中我们看到了Struts 1.1选择框(见图2),设置成功!

120361.jpg
图2

  接下来您就可以在JBuilder9里使用Struts1.1开发您的Web Application了

如何让500强HR一见钟情

教你成功面试拿offer全攻略
  • 2017年07月18日 12:49

Jbuilder9 - 如何加载Struts 1.1

1.下载Struts 1.1  jakarta-struts-1.2.42.解压缩到 %JBUILDER_PATH%/thirdparty3.打开Jbuilder 9[Tools]-[Config L...
  • meanson
  • meanson
  • 2005-04-13 22:42:00
  • 647

用JBuilder9 开发Struts实例

  • 2007年06月06日 16:52
  • 158KB
  • 下载

Jbuilder9.0+JBOSS-3.2+MS Server2000的配置方法

选择自 AbnerChai 的 Blog ,因为我要用到CMP,所以增加了JBOSS下使用MS Server的配置方法。网络上对Jbuilder9.0+JBOSS-3.2开发环境的配置说明的参考还很少...
  • gaoligaoli
  • gaoligaoli
  • 2004-12-14 14:52:00
  • 1096

在JBuilder9中运行最简单的Hibernate

(原文作者:hotmanhh) 在掌握了一些概念后,实现起来就比较简单了,hoho 我先把在JBuilder9中如何实现的写出来吧,再来写Tomcat的,感觉在Apps Server上应用的要多一些。...
  • xiaozhen
  • xiaozhen
  • 2004-06-27 08:41:00
  • 993

Jbuilder 9.0里光标错位问题的解决办法

Jbuilder 9.0里光标错位问题的解决办法  两中解决方法第一种:取得字体的粗体显示;第二种:修改font.properties.zh文件;步骤如下1. 用记事本打开C:/JBuilder9/j...
  • wayfoon322
  • wayfoon322
  • 2008-04-19 14:04:00
  • 614

jbuilder9安装

        本来不打算用jb的。反正现在机器档次也高了,况且人家还是要卖钱的东西,应该不会太差劲吧,先用用看了。1 下载靠,找的我头晕,好多站点都是有链无法下载。地址:http://campus....
  • p731
  • p731
  • 2005-02-04 10:35:00
  • 2002

JBuilder9光标错位解决方法

网上有不少的文章,但是有些是有问题的,但是有些文章给出的font.property是解决了光标错位问题,但是中文也变成了乱码了,下面给出的这个是我经过验证可以维持中文同时又解决了问题的。Jbuilde...
  • liswa
  • liswa
  • 2006-02-23 23:53:00
  • 1518

Jbuilder2006带来的麻烦事(JDK 版本问题)

Jbuilder2006自带的jdk版本是1.5的, 公司服务器上的jdk是1.4的版本, 以前的程序都是基于1.4版本开发的, 由此就产生了一些jdk版本冲突的问题(俺们的程序都是在自己的机器上写好...
  • noter
  • noter
  • 2007-05-22 09:18:00
  • 1212

jbuilder 9.0

  • 2008年04月14日 22:41
  • 3KB
  • 下载
收藏助手
不良信息举报
您举报文章:如何让JBuilder9支持Struts 1.1
举报原因:
原因补充:

(最多只允许输入30个字)