poj 1273 Drainage Ditches 【最大流入门 dinic算法】

Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 61113 Accepted: 23467

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50
题意:把池塘(编号1)里面的水通过若干个渠沟排到小溪(编号n)里面,每个渠沟都有最大容量,求能从池塘排出来的最大水量。 最大流模版
dinic:
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
#define MAXN 200+10
#define MAXM 500+10
#define INF 2000000000+10
using namespace std;
struct Edge
{
	int from, to, cap, flow, next;
}edge[MAXM];
int dist[MAXN], cur[MAXN], vis[MAXN], head[MAXN], top;
int n, m;
void init()
{
	top = 0;
	memset(head, -1, sizeof(head));
}
void addedge(int a, int b, int c)
{
	Edge E1 = {a, b, c, 0, head[a]};
	edge[top] = E1;
	head[a] = top++;
	Edge E2 = {b, a, 0, 0, head[b]};
	edge[top] = E2;
	head[b] = top++;
}
void getmap()
{
	int a, b, c;
	while(m--)
	{
		scanf("%d%d%d", &a, &b, &c);
		addedge(a, b, c);
	}
}
bool BFS(int start, int end)
{
	memset(dist, -1, sizeof(dist));
	memset(vis, 0, sizeof(vis));
	queue<int> Q;
	while(!Q.empty()) Q.pop();
	Q.push(start);
	vis[start] = 1;
	dist[start] = 0;
	while(!Q.empty())
	{
		int u = Q.front();
		Q.pop();
		for(int i = head[u]; i != -1; i = edge[i].next)
		{
			Edge E = edge[i];
			if(!vis[E.to] && E.cap > E.flow)
			{
				dist[E.to] = dist[u] + 1;
				vis[E.to] = 1;
				if(E.to == end) return true;
				Q.push(E.to);
			}
		}
	}
	return false;
}
int DFS(int x, int a, int end)
{
	if(x == end || a == 0) return a;
	int flow = 0, f;
	for(int& i = cur[x]; i != -1; i = edge[i].next)
	{
		Edge& E = edge[i];
		if(dist[E.to] == dist[x]+1 && (f = DFS(E.to, min(a, E.cap-E.flow), end)) > 0)
		{
			E.flow += f;
			edge[i^1].flow -= f;
			flow += f;
			a -= f;
			if(a == 0) break;
		}
	}
	return flow;
}
int Maxflow(int start, int end)
{
	int flow = 0;
	while(BFS(start, end))
	{
		memcpy(cur, head, sizeof(head));
		flow += DFS(start, INF, end);
	}
	return flow;
}
int main()
{
	while(scanf("%d%d", &m, &n) != EOF)
	{
		init();
		getmap();
		printf("%d\n", Maxflow(1, n));
	}
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值