hdoj 5100 Chessboard 【思维】



Chessboard

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 853    Accepted Submission(s): 352


Problem Description
Consider the problem of tiling an n×n chessboard by polyomino pieces that are k×1 in size; Every one of the k pieces of each polyomino tile must align exactly with one of the chessboard squares. Your task is to figure out the maximum number of chessboard squares tiled.
 

Input
There are multiple test cases in the input file.
First line contain the number of cases T ( T10000 ). 
In the next T lines contain T cases , Each case has two integers n and k. ( 1n,k100 )
 

Output
Print the maximum number of chessboard squares tiled.
 

Sample Input
      
      
2 6 3 5 3
 

Sample Output
      
      
36 24
 



题意:给定一个n*n的方格,现在用1*k的条去覆盖(必须可以放进去),问最多可以覆盖的格子数。


一开始掉gcd的坑里,花了将近1个小时才AC,发现数学题很有意思的O(∩_∩)O哈!


思路:考虑放条的方式,首先明确从外圈开始一圈一圈放无法每次都得到最优解。


放条方式有两种,但不管哪一种方式都会到达这个 下图这个状态 如图:以5*5 涂 1*3为例



最后剩余的那一部分有两种方案去涂,为了保证涂掉的面积足够大。显然不被涂的尺寸为min(5%3, 3-5%3)。

这样答案就出来了。


注意:n < k时是不能被填充的,结果为0。


AC代码:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#define INF 0x3f3f3f3f
#define eps 1e-8
#define MAXN 500000+10
#define MAXM 50000000
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
using namespace std;
int gcd(int a, int b){
    return b == 0 ? a : gcd(b, a%b);
}
int main()
{
    int t; Ri(t);
    W(t)
    {
        int n, k;
        Ri(n); Ri(k);
        int ans;
        if(n < k)
            ans = 0;
        else
        {
            int temp = min(k - n % k, n % k);
            ans = n * n - temp * temp;
        }
        printf("%d\n", ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值