poj 3258 River Hopscotch 【二分】

River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9859 Accepted: 4211

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di <L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:  LN, and  M 
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing  M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).


题意:给定长为L的区间,起点为0,终点为L。区间里面全是水,水面上有N个岩石,已经给出每个岩石与起点的距离。现在你可以从N个岩石中移走M个,要求从起点到终点每次跳跃的最小距离最大化。


二分,对当前的查找值mid:

找到第一个与起点i距离大于等于mid值的岩石j,去掉中间的j-i个岩石,然后更新起点继续模拟直找终点,统计去掉的岩石数目是否小于等于M。


AC代码:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <vector>
#define INF 0x3f3f3f
#define eps 1e-8
#define MAXN (50000+1)
#define MAXM (100000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
int a[MAXN];
bool judge(int o, int n, int m)
{
    int cnt = 0, pre = 0;
    for(int i = 0; i <= n; )
    {
        //printf("%d %d\n", pre, a[i]);
        if(a[i] - pre >= o)
        {
            pre = a[i];
            i++;
        }
        else
        {
            int j = i;
            while(j <= n && a[j] - pre < o)
                j++;
            //printf("%d %d\n", a[i], a[j]);
            if(j > n)
                j--;
            cnt += j - i;
            pre = a[j];
            i = j + 1;
            if(i > n)
                break;
         }
    }
    //printf("%d\n", cnt);
    return cnt <= m;
}
int main()
{
    int L, N, M;
    while(scanf("%d%d%d", &L, &N, &M) != EOF)
    {
        for(int i = 0; i < N; i++)
            Ri(a[i]);
        sort(a, a+N);
        int l = 0, r = L;
        a[N] = L; int ans;
        while(l <= r)
        {
            int mid = (l + r) >> 1;
            if(judge(mid, N, M))
            {
                ans = mid;
                l = mid+1;
            }
            else
                r = mid-1;
        }
        Pi(ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值