hdoj 1078 FatMouse and Cheese 【dp】

题目链接:hdoj 1078 FatMouse and Cheese

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7781 Accepted Submission(s): 3223

Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he’s going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse – after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) … (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), … (1,n-1), and so on.
The input ends with a pair of -1’s.

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.

Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output
37

题意:n*m的矩阵,从(1, 1)出发,每次横着或竖着走最多k步,要求下一位置的元素值大于上一位置的元素值,问你可以获得的最大元素和。

思路:水dp,套个记忆化就好了。

AC代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
typedef long long LL;
const int MAXN = 1e6 +10;
const int INF = 0x3f3f3f3f;
int dp[110][110];
int Map[110][110];
int n, k;
int M[4][2] = {1,0, 0,1, -1,0, 0,-1};
bool judge(int x, int y) {
    return x >= 1 && x <= n && y >= 1 && y <= n;
}
int DFS(int x, int y) {
    if(dp[x][y] != -1) return dp[x][y];
    int ans = Map[x][y];
    for(int i = 1; i <= k; i++) {
        for(int j = 0; j < 4; j++) {
            int nx = x + M[j][0] * i;
            int ny = y + M[j][1] * i;
            if(judge(nx, ny) && Map[nx][ny] > Map[x][y]) {
                ans = max(ans, DFS(nx, ny) + Map[x][y]);
            }
        }
    }
    return dp[x][y] = ans;
}
int main()
{
    while(scanf("%d%d", &n, &k), n != -1 || k != -1) {
        for(int i = 1; i <= n; i++) {
            for(int j = 1; j <= n; j++) {
                scanf("%d", &Map[i][j]);
                dp[i][j] = -1;
            }
        }
        DFS(1, 1);
        int ans = 0;
        for(int i = 1; i <= n; i++) {
            for(int j = 1; j <= n; j++) {
                ans = max(ans, dp[i][j]);
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值