Y2K Accounting Bug

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

分析:ms公司由于某病毒导致数据流失,该公司的盈(s)亏(d)是一定的,每五个月记录一次财务报表,这五个月总额为亏,问一年中是否盈利,如果盈利的话,求最大盈利值,反正输出Deficit。
    亏一个月(d > 4*s): ssssd ssssd ss 
    亏两月(2*d > 3*s): sssdd sssdd ss
    亏三月(3*d > 2*s): ssddd ssddd ss
    亏四个月(4*d > s): sdddd sdddd sd
    亏

参考代码:
#include<cstdio>
#include<cmath>
#include<cstdlib>
#include<cctype>
#include<cstring>
#include<string>
#include<sstream>
#include<algorithm>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#include<iostream>

using namespace std;
int s,d;

int main()
{
    while( ~scanf("%d%d",&s,&d))
    {
        int ans;
        if( d > 4*s)//每五个月亏一个月
            ans = 10*s-2*d;
        else if( 2*d > 3*s)//每五个月亏两月
            ans = 8*s-4*d;
        else if( 3*d > 2*s)//每五个月亏三月
            ans = 6*s-6*d;
        else if( 4*d > s)//每五个月亏四月
            ans = 3*s-9*d;
        else
        {
            printf("Deficit\n");
            continue;
        }
        if( ans < 0)
            printf("Deficit\n");
        else
            printf("%d\n",ans);

    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值