HDU2095-find your present (2)

 

问题描述

find your present (2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/1024 K (Java/Others)
Total Submission(s): 9613    Accepted Submission(s): 3534


Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

 

Input
The input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

 

Output
For each case, output an integer in a line, which is the card number of your present.
 

 

Sample Input
5
1 1 3 2 2
3
1 2 1
0
 

 

Sample Output
3
2
Hint
Hint
use scanf to avoid Time Limit Exceeded
 

 

Author
8600
 

 

Source
 

 

Recommend
8600

算法分析

Problem Analyse

 在新年聚会上,所有人都会收到一份特殊的礼物。选择轮到你领取自己的礼物了。在桌子上有一大堆礼物,其中只有一个是你的。每个礼物上都标有一个号码。而你的礼物的号码是与其他所有礼物都不相同的。你可以假定只有一个数字只出现一次。例如,现在有5个礼物,他们分别标号伪1,2,3,2,1。所以,你的礼物就是标号为3的那个。因为3只出现了1次。

 

Algorithm Analyse

 用哈希记录所有出现过的数字的个数,最后出现一次的就是结果。

 

解决方案

 

#include <set>
#include <map>
#include <cstdio>
using namespace std;
int main()
{
    int n,i,t;
    set<int> s;
    set<int>::iterator it;
    map<int,int>m;while(scanf("%d",&n),n)
    {
        s.clear();
        m.clear();
        for(i=0;i<n;i++)
        {
            scanf("%d",&t);
            s.insert(t);
            m[t]++;
        }
        for(it=s.begin();it!=s.end();it++)
        {
            if(m[*it]==1)
            {
                printf("%d\n",*it);
                break;
            }
        }
    } 
} 

 

 

 

转载于:https://my.oschina.net/OceanEyes/blog/381490

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值