我的ACM之 1.2.1 A+B Coming


     Input may contain multiple test cases. Each case contains A and B in one line.
     A, B are hexadecimal number.
     Input terminates by EOF.
Output
     Output A+B in decimal number in one line.
Sample Input
     1 9
     A B
     a b
Sample Output
     10
     21
     21

 

import java.util.*;

public class Main {
	 public static void main(String[] args){
		 Scanner s = new Scanner(System.in);
			 String m,n;
		 while (s.hasNext()){
			 m=s.next();
			 n=s.next();
			 int i = Integer.parseInt(m, 16);
			 int j = Integer.parseInt(n, 16);
			 System.out.println(i+j);
			 }	 
	}
}
总结: 重点在于 一个以字符串形式的16进制的数如何转化为int

转载于:https://my.oschina.net/u/584403/blog/118686

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值