LightOJ - 1104 Birthday Paradox (期望DP)

Birthday Paradox

 

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output

For each case, print the case number and the desired result.

Sample Input

2

365

669

Sample Output

Case 1: 22

Case 2: 30

题目链接:https://vjudge.net/problem/LightOJ-1104

题目大意:这个星球上一年有n天,要求晚会上至少有两个人在同一天生日的概率要大于等于0.5,问至少要邀请多少人来参加晚会

思路:没有同一天生日的人的概率是P=(n-1)/n * (n-2)/n * (n-3)/n......(n-i)/n ,要使至少两人同一天生日的概率大于等于0.5,那么就是要使没有人同一天生日的概率小于等于0.5;

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t,T=1;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        double x=1;
        int i=1;
        while(i<n)
        {
            if(i==n) break;
            x*=1.0*(n-i)/n;
            if(x<=0.5) break;
            i++;
        }
        printf("Case %d: %d\n",T++,i);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值