PAT——A1046

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

提交代码

#include<stdio.h>
int main(){
	int N,a[100000]={0},t,count=0;
	scanf("%d",&N);//N表示即将要输入的exits数; 
	for(int i=2;i<=N;i++){
		scanf("%d",&t);//t表示即将输入的每两个exits之间的distance; 
		a[i]=a[i-1]+t;//a[i]表示1-st exit to i-th 的 total distance; 
	}
	scanf("%d",&t);//this input is the last in N, this 't' is the distance of N-th to 1-st;
	count=a[N]+t;//count equal 前N个出口总距离 + 最后一个输入的第N个exit到第一个exit的距离; 
	int M,x,y,m=0;
	scanf("%d",&M);
	while(M--){
		scanf("%d %d",&x,&y);
		if(x>y){
			int temp=x;
			x=y;
			y=temp;
		}
		m=a[y]-a[x];//m is the distance of x-th to y-th; 
		int min=m<(count-m)? m:(count-m);//short distance need comparing;
		printf("%d\n",min);
		m=0;
	}
}

注意点:一开始我是数组表示每两个exits之间距离,底下求x-y距离时就要用到循环,而此循环是嵌套在while(M--)里的,时间复杂度就变成N^2了,在PAT第三个多点测试就会出现运行超时,所以稍作修改:用数组表示第1个exit到第i个exit之间总距离,这样下面求x-y距离时就可以不用循环。这里的整个环cycle总距离等于第1个exit到第N个exit的总距离 + 最后输入的N到第一个之间的距离。

 

转载于:https://my.oschina.net/u/3170021/blog/906325

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值