poj3301Texas Trip

Texas Trip
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3269 Accepted: 966

Description

After a day trip with his friend Dick, Harry noticed a strange pattern of tiny holes in the door of his SUV. The local American Tire store sells fiberglass patching material only in square sheets. What is the smallest patch that Harry needs to fix his door?

Assume that the holes are points on the integer lattice in the plane. Your job is to find the area of the smallest square that will cover all the holes.

Input

The first line of input contains a single integer T expressed in decimal with no leading zeroes, denoting the number of test cases to follow. The subsequent lines of input describe the test cases.

Each test case begins with a single line, containing a single integer n expressed in decimal with no leading zeroes, the number of points to follow; each of the followingn lines contains two integers x and y, both expressed in decimal with no leading zeroes, giving the coordinates of one of your points.

You are guaranteed that T ≤ 30 and that no data set contains more than 30 points. All points in each data set will be no more than 500 units away from (0,0).

Output

Print, on a single line with two decimal places of precision, the area of the smallest square containing all of your points.

Sample Input

2
4
-1 -1
1 -1
1 1
-1 1
4
10 1
10 -1
-10 1
-10 -1

Sample Output

4.00
242.00
#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const double EPS = 1e-10;
const double maxn=0xfffffffffffff;
const double minn=-0xfffffffffffff;
const double PI=acos(-1.0);

double x[39],y[39];
int n;



double Cal(double a)
{
	double maxx=minn,minx=maxn,maxy=minn,miny=maxn;
	for(int i=1;i<=n;i++)
	{
		double tx,ty;
		tx=x[i]*cos(a)-y[i]*sin(a);
		ty=y[i]*cos(a)+x[i]*sin(a);

		maxx=max(maxx,tx);
		minx=min(minx,tx);
		maxy=max(maxy,ty);
		miny=min(miny,ty);
	}

	return max(maxx-minx,maxy-miny);
}

double Solve(void)
{
	double Left, Right;
	double mid, midmid;
	double mid_value, midmid_value;
	Left = 0; Right = PI;
	while (Left + EPS < Right)
	{
		mid = (Left + Right) / 2;
		midmid = (mid + Right) / 2;
		mid_value = Cal(mid);
		midmid_value = Cal(midmid);
		if (mid_value <= midmid_value) Right = midmid;
		else Left = mid;
	}
	return Cal(Left);
}

int main()
{
	freopen("in.txt","r",stdin);
	int t;
	cin>>t;
	while(t--)
	{
		cin>>n;
		for(int i=1;i<=n;i++)
			cin>>x[i]>>y[i];
		double ans = Solve();
		printf("%.2lf\n",ans*ans);
	}
	return 0;
}


转载于:https://my.oschina.net/N3verL4nd/blog/866894

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值