HOJ C - Portal——并查集+离线

C - Portal
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

ZLGG found a magic theory that the bigger banana the bigger banana peel .This important theory can help him make a portal in our universal. Unfortunately, making a pair of portals will cost min{T} energies. T in a path between point V and point U is the length of the longest edge in the path. There may be lots of paths between two points. Now ZLGG owned L energies and he want to know how many kind of path he could make.

Input

There are multiple test cases. The first line of input contains three integer N, M and Q (1 < N ≤ 10,000, 0 < M ≤ 50,000, 0 < Q ≤ 10,000). N is the number of points, M is the number of edges and Q is the number of queries. Each of the next M lines contains three integers a, b, and c (1 ≤ a, b ≤ N, 0 ≤ c ≤ 10^8) describing an edge connecting the point a and b with cost c. Each of the following Q lines contain a single integer L (0 ≤ L ≤ 10^8).

Output

Output the answer to each query on a separate line.

Sample Input

10 10 10
7 2 1
6 8 3
4 5 8
5 8 2
2 8 9
6 4 5
2 1 5
8 10 5
7 3 7
7 8 8
10
6
1
5
9
1
8
2
7
6

Sample Output

36
13
1
13
36
1
36
2
16
13


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<stack>
#include<set>
using namespace std;
const int N= 10003;
const int M= 50002;
struct  Node
{
    int u,v;
    int len;
} edge[M];
bool cmp(Node a,Node b)
{
    return a.len<=b.len;
}
int fa[N];
int sum[N];//以该节点所在的集合点的数量
int n,m,q;
void init()
{
    for(int i=1; i<=n; i++)
        fa[i]=i,sum[i]=1;
}
int findx(int x)
{
    return fa[x]=fa[x]==x?x:findx(fa[x]);
}
int Union(int a,int b)
{
    int aa=findx(a);
    int bb=findx(b);
    if(aa==bb)
        return 0;
    else if(fa[aa]<fa[bb])
    {
        fa[bb]=aa;
        int tmp=sum[aa]*sum[bb];
        sum[aa]+=sum[bb];
        return tmp;
    }
    else
    {
        fa[aa]=bb;
        int tmp=sum[aa]*sum[bb];
        sum[bb]+=sum[aa];
        return tmp;
    }
}

int ans[N];
struct Q
{
    int L;
    int id;
    int ans;
} que[N];
bool cmp1(Q a,Q b)
{
    return a.L<=b.L;
}
bool cmp2(Q a,Q b)
{
    return a.id<b.id;
}
int main()
{
    while(scanf("%d%d%d",&n,&m,&q)!=EOF)
    {
        init();
        for(int i=0; i<m; i++)
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].len);
        for(int i=0; i<q; i++)
            {scanf("%d",&que[i].L);que[i].id=i;que[i].ans=0;}
        sort(edge,edge+m,cmp);//边按边长进行排序
        sort(que,que+q,cmp1);
        int cnt=0;
        //主要思想:每增加一条边,就会算出其增加的路径,然后更新sum[],fa[];
        //其实就是算出一个图中包含的所有路径,只不过根据条件和询问,该成了分阶段输出值
        for(int i=0; i<q; i++)
        {
            while(edge[cnt].len<=que[i].L&&cnt<m)
            {
                //cout<<"FFF"<<endl;
                int aa=findx(edge[cnt].u);
                int bb=findx(edge[cnt].v);
                if(aa==bb)
                {
                    cnt++;
                    continue;
                }
                else
                {
                    que[i].ans+=Union(edge[cnt].u,edge[cnt].v);
                    cnt++;
                }
            }
            if(i>=1)
                que[i].ans+=que[i-1].ans;
        }
        sort(que,que+q,cmp2);
        for(int i=0; i<q; i++)
        {
           printf("%d\n",que[i].ans);
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值