POJ 2689 Prime Distance 二次筛选

5 篇文章 0 订阅

                                                                 Prime Distance 

  
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8409 Accepted: 2273

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source


题意 :求给定区间内相邻两素数距离最大的和最小的
思路 :此题数据范围太大,暴力是肯定不行的,因为询问区间长度是1000000,比较小,故可以选用二次筛选的方法:筛选[x,n]区间的所有素数可以用[1,sqrt(n)]之间的素数来筛选。因此此题实际保存的素数数组大小只要sqrt(2147483647)<50000就行了,这个是可以接受的。题目有很多坑,做的时候需仔细。
AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define MAX 50000
bool is[MAX * 20 + 1];
int xmax , ymax , xmin , ymin , prime[MAX];
int getprm(int n) {
	int c = 0,e = sqrt(1.0 * n) + 1;
	memset(is, true, sizeof(is));
	prime[c++] = 2;
	is[0] = is[1] = false;//特别注意特殊值1
	for (int i = 4; i < n; i += 2)is[i] = false;
	for (int i = 3; i < n; i += 2)if (is[i]) {
			prime[c++] = i;
			if (i < e) for (int k = i * 2, j = i * i; j < n; j += k)is[j] = false;
		}
	return c;
}
void regetprm(int l, int r) {
	memset(is, true, sizeof(is));
	if (l == 1) is[0] = false;//这里特别容易坑,此处排除的是特殊值1.否则样例 1 2过不去
	int e = sqrt(1.0 * r) + 1;
	for (int i = 0;prime[i] < e; i++) {
		int st = l /prime[i] + (l % prime[i] ? 1:0);//若prime[i]>l那么因为l>1还是会加1
		int ed = r / prime[i];
		if (st == 1) st++;
		for (int j = st; j <= ed; j++) {
			is[j * prime[i] - l] = false;
		}
	}
}
bool getans(int n, int m) {
	int max = -1,min = 10000005,pos,pos1 = 0;
	while (pos=pos1,1) {
		while (pos < n && !is[pos])pos++;
		pos1 = pos + 1;
		while (pos1 < n && !is[pos1])pos1++;
		if (pos1 >= n) break;
		int len = pos1 - pos;
		if (max < len) {max = len, xmax = pos + m, ymax = pos1 + m;}
		if (min > len) {min = len, xmin = pos + m, ymin = pos1 + m;}
	}
	if (max == -1) return false;
	else return true;
}
int main(int argc, char **argv) {
	int l, r;
	getprm(MAX);
	while (~scanf("%d%d", &l, &r)) {
		regetprm(l, r);
		if (getans(r - l + 1, l)) {
			printf("%d,%d are closest, ",xmin,ymin);
			printf("%d,%d are most distant.\n",xmax, ymax);
		}
		else puts("There are no adjacent primes.");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值