DB2-Express C 在Linux AS 5中安装中libstdc++.so.5的问题

版权声明:转载时请以超链接形式标明文章原始出处和作者信息及本声明
http://gang613.blogbus.com/logs/25049832.html

在Linux  AS 5上安装DB2-Express  C 时,出现了错误,信息如下:
/usr/lib/libstdc++.so.5 version 'CXXABI_1.2' not found(required by ...... /bin/db2usrinf)

在有些Linux版本中libstdc++.so.5并不存在,或者被Link到了/usr/lib64/libstdc++.so.6.0.3,类似于libstdc++.so.6。

我检查了一下,发现libstdc++.so.5被Link到libstdc++.so.6.0.8。再通过命令检查其中的CXXABI版本:

$ strings /usr/lib/libstdc++.so.6.0.3 | grep CXXABI
CXXABI_1.3            //果然不是CXXABI_1.2

解决办法是安装合适的libstdc++.so.5。我下载了      compat-libstdc++-33-3.2.3-63.i386.rpm 。

$ rpm --install --force libstdc++-33.3.2.3-63.i386.rpm

然后检查:

$ strings /usr/lib/libstdc++.so.5 | grep CXXABI
CXXABI_1.2       //已经是合适的版本了

最后再安装Db2,就不再报错了。 

 参考资料:How to resolve oninit error: /lib64/libstdc++.so.5: version `CXXABI_1.2' not found

展开阅读全文

没有更多推荐了,返回首页