Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.
|
Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities. To make it easy, the cities are signed from 1 to n. Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q. Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities. |
Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
|
Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6
|
Sample Output
1
|
Author
dandelion
|
Source
HDOJ Monthly Contest – 2010.04.04
|
并查集把已经相连的先用并查集合并。之后便是最小生成树算法。
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
struct node{
int a;
int b;
int dis;
}p[4000000];
bool cmp(node n1,node n2)
{
return n1.dis<n2.dis;
}
int parent[10000];
int num[10000];
void init(int n)
{
for(int i=1;i<=n;i++)
{
parent[i]=i;
num[i]=1;
}
}
int find(int a)
{
if(a==parent[a])
return a;
parent[a]=find(parent[a]);
return parent[a];
}
void combine(int a,int b)
{
if(num[a]<num[b])
{
parent[a]=b;
num[b]+=num[a];
}
else
{
parent[b]=a;
num[a]+=num[b];
}
}
int main()
{
//freopen("in.txt","r",stdin);
int n,m,k;
int i,j;
int icase;
cin>>icase;
while(icase--)
{
scanf("%d%d%d",&n,&m,&k);
init(n);
for(i=1;i<=m;i++)
{
scanf("%d%d%d",&p[i].a,&p[i].b,&p[i].dis);
}
int count;
for(i=m+1;i<=m+k;i++)
{
cin>>count;
int p,q;
cin>>p;
for(j=2;j<=count;j++)
{
cin>>q;
int f1=find(p);
int f2=find(q);
if(f1!=f2)
{
combine(f1,f2);
n--;
}
}
}
sort(p+1,p+m+1,cmp);
int res=0;
for( i=1;i<=m;i++)
{
int a=p[i].a;
int b=p[i].b;
int p1=find(a);
int p2=find(b);
if(p1!=p2)
{
combine(p1,p2);
res+=p[i].dis;
n--;
}
}
if(n==1)
cout<<res<<endl;
else
cout<<-1<<endl;
}
return 0;
}