HDOJ1086 线段相交问题

转载出处:点击打开链接


You can Solve a Geometry Problem too

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11215    Accepted Submission(s): 5537


Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point. 
 

Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the number of intersections, and one line one case.
 

Sample Input
  
  
2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0
 

Sample Output
  
  
1 3
 

Author
lcy
 

Recommend
We have carefully selected several similar problems for you:   1115  1392  2150  1348  1147 

给定n条线段,求解所有线段的交点个数。不是直线,直线的话太容易了,只要斜率 不一样便是相交。

     两条线段相交也就意味着一个线段的两个端点跨立另一条线段的两侧。于是向量叉积的几何意义便得到了运用。如果两个点P1,P2在一条线段Q1Q2两侧,那么向量P1Q1*P1Q2必然和P2Q1*P2Q2异号,或者其中一者为零,那么P1, P2必然在线段Q1Q2的两侧。在判断Q1Q2是否在P1P2的两侧便可判断两线段是否相交。


#include<iostream>  
#include<stdio.h>  
using namespace std;  
  
const int Max = 110;  
  
struct Point  
{  
    double x, y;  
};  
  
struct Segment  
{  
    Point s, e;  
};  
  
Segment s[Max];  
  
double product(Point &a, Point &b, Point &c)  
{  
    double x1, y1, x2, y2;  
    x1 = a.x - c.x, y1 = a.y - c.y;  
    x2 = b.x - c.x, y2 = b.y - c.y;  
    return x1 * y2 - y1 * x2;  
}  
  
bool intersect(Segment &a, Segment &b)  
{  
    return product(a.s, a.e, b.s) * product(a.s, a.e, b.e) <= 0 &&   
        product(b.s, b.e, a.s) * product(b.s, b.e, a.e) <= 0;  
}  
  
int main()  
{  
    int n, cnt;  
    while(scanf("%d", &n) && n)  
    {  
        for(int i=0; i<n; i++)   
            scanf("%lf %lf %lf %lf", &s[i].s.x, &s[i].s.y, &s[i].e.x, &s[i].e.y);  
              
        cnt = 0;  
        for(int i=0; i<n; i++)  
            for(int j=i+1; j<n; j++)  
                if(intersect(s[i], s[j])) cnt ++;  
        printf("%d\n", cnt);  
    }  
    system("pause");  
    return 0;  
}  




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值