Best Reward (扩展KMP+回文串)

http://acm.hdu.edu.cn/showproblem.php?pid=3613

Best Reward


Problem Description
After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit. 

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.) 

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li. 

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero. 

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value. 

 

Input
The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows. 

For each test case, the first line is 26 integers: v 1, v 2, ..., v 26 (-100 ≤ v i ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind. 

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v 1, the value of 'b' is v 2, ..., and so on. The length of the string is no more than 500000. 

 

Output
Output a single Integer: the maximum value General Li can get from the necklace.
 

Sample Input
  
  
2 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 aba 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 acacac
 

Sample Output
  
  
1 6
 
题目大意:
给个字符串S,要把S分成两段T1,T2,每个字母都有一个对应的价值,如果T1,T2是回文串(从左往右或者从右往左读,都一样),那么他们就会有一个价值,这个价值是这个串的所有字母价值之和,如果不是回文串,那么这串价值就为0。问最多能获得多少价值?
 
对于我们只需要枚举扫描一遍extend数组,扫描到的当前位置之前为前半部分T1, 然后用根据extend数组可以判断T1是否是回文。那后半部分T2呢?  刚才是用S去匹配T, 如果要求后缀,只需要用T去匹配S,再得到一个数组extend2即可,根据这个extend2判断后半部分T2是否是回文。
 
一定要分成两部分噢,不能不分。如样例1
#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
const int maxn=500010;
char str1[maxn],str2[maxn];
int sum[maxn],v[27];
int next[maxn];
int extend1[maxn],extend2[maxn];
void ekmp(char s[],char t[],int next[],int extend[])
{
    int i,j,p,L;
    int lens=strlen(s);
    int lent=strlen(t);
    next[0]=lent;
    j=0;
    while(j+1<lent&&t[j]==t[j+1])j++;
    next[1]=j;
    int a=1;
    for(i=2;i<lent;i++)
    {
        p=next[a]+a-1;
        L=next[i-a];
        if(i+L<p+1)next[i]=L;
        else
        {
            j=max(0,p-i+1);
            while(i+j<lent&&t[i+j]==t[j])j++;
            next[i]=j;
            a=i;
        }
    }
    j=0;
    while(j<lens&&j<lent&&s[j]==t[j])j++;
    extend[0]=j;
    a=0;
    for(i=1;i<lens;i++)
    {
        p=extend[a]+a-1;
        L=next[i-a];
        if(L+i<p+1)extend[i]=L;
        else
        {
            j=max(0,p-i+1);
            while(i+j<lens&&j<lent&&s[i+j]==t[j])j++;
            extend[i]=j;
            a=i;
        }
    }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        for(int i=0;i<26;i++)
            scanf("%d",&v[i]);
        scanf("%s",str1);
        int len=strlen(str1);
        sum[0]=0;
        for(int i=0;i<len;i++)
        {
            sum[i+1]=sum[i]+v[ str1[i]-'a'];
            str2[i]=str1[len-i-1];
        }
        str2[len]=0;
        ekmp(str2,str1,next,extend1);
        ekmp(str1,str2,next,extend2);
        int ans=-100000;
        for(int i=1;i<len;i++)
        {
            int tmp=0;
            if(i+extend1[i]==len)tmp+=sum[len-i];
            int pos=len-i;
            if(pos+extend2[pos]==len)tmp+=sum[len]-sum[pos];
            if(tmp>ans)ans=tmp;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值