android studio 3.0之后Unable to resolve dependency for ':app@debug/compileClasspath':

原创 2018年04月15日 09:15:06

Unable to resolve dependency for ‘:app@debug/compileClasspath’: Could not resolve com.android.support:appcompat-v7:26.1.0

这里写图片描述

升级了android studio 3.0 之后,就莫名的发生了很多错误,新建的项目一样有一堆的错误,gradle 也无法更新,有人说是网络问题,有人说要翻墙,各种百度,各种谷歌都没能解决问题。然后就是无奈的卸载重装,绝望的是仍然还是不行,都快想放弃了,被折腾了一个星期。

这里写图片描述

解决的方法就是把compileSdkVersion 27降低了,我是依次降低的,改26也不行,最后我改为compileSdkVersion 25就可以将错误解决了,估计这不是最终的解决方法,但低版本的起码没跑错了,能跑起来了。笔者是个小菜鸟,对于这个问题的根源不清楚,希望懂的大神不吝赐教。


后续更新

今天家里没有网络,发现新建的项目还是会报这个错误,然后拿手机开了热点,然后重新打开android studio 没有出现上述问题, 笔者怀疑可能是网络问题造成的上述问题。 之所以之前不确定是不是网络问题,是因为笔者家里有两台电脑,一台电脑没有问题,一台电脑有问题,所以首先就排除了网络原因。现在看来很大可能是网络问题造成的。

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/csdn2314/article/details/79946586

升级AndroidStudio3.0 Unable to resolve dependency for ':app@betaUnitTest/compileClasspath': Could not

AndroidStudio3.0升级报了下面的错误:Unable to resolve dependency for ':app@betaUnitTest/compileClasspath': Cou...
  • monkin2011
  • monkin2011
  • 2017-11-02 17:56:30
  • 31667

studio3.0关于Error:Unable to resolve dependency for ':@debug/compileClasspath'的解决方案

如果你在老项目迁移到studio3.0时遇到了同样的问题,希望可以帮到你。 如果你有这类似的错误,可以尝试尝试。把这种依赖方式debugCompile project(path: "CordovaL...
  • z_Xiaozuo
  • z_Xiaozuo
  • 2018-01-03 16:31:45
  • 15803

Android Studio 3.0 导入项目报Error:Unable to resolve dependency for ':@debug/compileClasspath'错误的解决方案

之前使用Cordova CLI 生成的android 项目模板,在升级Android Studio 至3.0版本后,导入项目报如下错误:Android Studio 升级到3.0版本,gradle 会...
  • newsuperior
  • newsuperior
  • 2018-03-21 14:30:03
  • 201

升级Android Studio 3.0,报Unable to resolve dependency

Android Studio 3.0正式版已发布,于是赶紧升级体验了一波。不出意外,果然项目有兼容问题,什么问题呢?日志如下: Error:Unable to resolve dependency ...
  • shadow066
  • shadow066
  • 2017-10-27 23:19:16
  • 17843

android 添加依赖出现Failed to resolve:"你添加的依赖名" 或者出现 debug@Compileclasspath问题

首先出现的问题是 debug@Compileclasspath的问题,经过一波百度之后都说是AS build.gradle版本3.0以上的问题,但是经过一波修改之后并没有什么卵用,并没有解决这个问题,...
  • lyh1299259684
  • lyh1299259684
  • 2017-11-18 11:47:01
  • 4998

gradle升到4.4后,报Unable to resolve dependency for ':app@debug/compileClasspath':

Android studio可以升级到3.1了,默认用的是gradle4.4修改为distributionUrl=https\://services.gradle.org/distributions/...
  • magicbaby810
  • magicbaby810
  • 2018-04-08 10:41:29
  • 350

Android 异常Error:Unable to resolve dependency ,Could not resolve project

1.Error:Unable to resolve dependency for ':app@googlePaidUatUnitTest/compileClasspath': Could not re...
  • danqi1989
  • danqi1989
  • 2017-11-17 17:11:22
  • 4113

Unable to resolve dependency for ':okgo@debug/compileClasspath': Could not resolve com.squareup.okh

Unable to resolve dependency for ':okgo@debug/compileClasspath': Could not resolve com.squareup.okht...
  • hahaha_1107
  • hahaha_1107
  • 2018-01-01 18:11:08
  • 870

Android studio 3.x 报错 : Unable to resolve dependency for ':app@dexOptions/compileC

解决方案: 1.检查依赖和被依赖module中的 buildTypes {},二者包含子项( release {} debug{}…)要相同。 2.大招:升级gradle4.x至更高版...
  • u010296640
  • u010296640
  • 2018-01-20 14:48:35
  • 1535
收藏助手
不良信息举报
您举报文章:android studio 3.0之后Unable to resolve dependency for ':app@debug/compileClasspath':
举报原因:
原因补充:

(最多只允许输入30个字)